Bluetooth

Semi Bluetooth Success

Send to Kindle

For those who read this space regularly, you know that the one thing I’ve struggled with on my otherwise perfect new laptop is getting my Treo 755p working with Vista x64. The USB Cable option simply isn’t available, as Palm is too busy dying to support an up-and-coming version of the most popular operating system in history…

But, many people report success using Bluetooth to sync (and dial up I guess). I wasn’t able to get either working, even though I was able to pair the phone to my laptop (it has a built-in BT radio). I admit that I didn’t kill myself to get it going, but I tried many things.

Today, I decided to try again (given the hassles that I had on our trip this past weekend to Birmingham, where I connected through Lois’ old laptop using ICS). I found instructions on the Palm website for connecting Windows DUN via Bluetooth to a Treo 755p.

When I tried it, I got the same error that I did previously, “modem already in use”. This time, I had a clue (last time I didn’t). In messing around today, I deleted the original pairing, leaving myself without a device. Somehow, that hung Hotsync Manager. When I killed and restarted it, it said that it couldn’t connect to Serial Port COM41, but would connect automatically if it became available!

Aha, that was the clue I was missing, that somehow, Hotsync Manager was successfully grabbing the Serial Port, even though it wasn’t correctly syncing! After re-pairing (not repairing) 😉 I quit Hotsync Manager, and then did the normal DUN dance on the PC (with Sprint, you dial #777 with no username/password). I pay for full Phone-as-Modem (PAM) from Sprint, but on XP I use their Sprint Broadband Connection Manager application (which won’t even install on Vista x64!).

Voila, it dialed and authenticated right away. I had a semi-pokey connection, 341Kbps download and 105Kbps upload, but hey, that’s infinitely better than no connection at all!

At least now we don’t both need to share one connection. That’s not the big win though. At some point, Lois might actually want to switch to her new laptop (don’t hold your breath, I stopped holding mine!) 😉 and when that happens, we wouldn’t have had any Treo connectivity. Now each of us will be able to use our phones via BT if/when necessary. I continue to hope to never need such a connection, but at least I’m not as likely to cancel the insurance premium just yet, now that I know it works.

Sprint will continue to get a crazy premium from me for the moment, until an Android phone that I like becomes available. Now if I can only figure out how to sync via BT (others claim it works perfectly, but my phone hangs every time, instantly)… 🙁

Sometimes technology lets you down :-(

Send to Kindle

I forced myself to take my long walk today. As usual, I am extremely glad that I did, but for one thing. I walk with an iPod, with a Logitech Bluetooth headset. For the first leg of my walk, I was listening to Wicked (I know, huge surprise) 😉 but in the middle of “Wonderful”, it stopped playing.

It could have been any of the three devices running out of their battery charge (the iPod, the BT transmitter, and the headset/receiver). A quick check revealed that all were charged up.

Turns out the iPod was simply on the fritz. This happened once before, nearly a year ago, so it’s probably not something I need to worry about.

I forgot how do the reset. I could have called Lois, and had her Google it, but I didn’t care enough. I walked the rest of the way (another 80 minutes) in a more “walking meditation” state, which was fine too.

I don’t know why I didn’t remember the iPod reset dance:

  1. Slide the hold switch so that it’s on hold.
  2. Slide the hold switch so that it’s off.
  3. Press the Menu and Center buttons simultaneously for 10 seconds.
  4. Wait for the Apple logo.

If you see the logo, you’re done, it’s rebooting. If not, there are deeper tricks to try. Mine worked, and it’s charging back up now, since it continued to drain the battery the entire way home, even though it wouldn’t play a single song…