Trigger pulled on new PC, a UM790 Pro from Minisforum

Send to Kindle

Even shorter than a TL;DR, you can tell what machine I bought right in the title above. But, do I like it? Perhaps that deserves a TL;DR so you don’t fall asleep reading the rest of the post…


I absolutely love this mini-PC. It’s the UM790 Pro from Minisforum. I bought it barebones, while it was still in pre-order. It’s still available at the same price I paid ($519), which is pretty incredible.

OK, if you’re still here, there are lots of details coming…

My last post was nearly three months ago (I know, I’ve been lazy, and I’m not happy about it, even if you are!). That post was the one contemplating this exact purchase. In it I laid out five bullet points that I wanted in a new PC. The UM790 Pro satisfies every single one of those. In that post, I also listed the machines I’d consider if I had to pull the trigger that day. The UM790 Pro was not on the list. There was an Intel-based Minisforum machine on the list (for $30 less).

I’m thankful that I didn’t have to pull the trigger then, because none of the other machines satisfied all five criteria. Not too long after writing the post, the UM790 and UM790 Pro were announced, but not yet available for pre-order. A very short while later, pre-orders opened up.

I still didn’t pull the trigger (not that I waited long), because my ancient laptop was still functioning perfectly (it still is, even though it hasn’t been turned on, other than to keep it up-to-date, in a month!). But, fairly quickly, I realized that a machine that satisfied every desire that I had (not all of them were requirements), at a very attractive price, shouldn’t be ignored.

I placed the order on May 29th, 2023. They estimated that it would ship in early July (from China, which sometimes has long shipping times). We were expecting to be in NYC for much of July, so I had the machine shipped there. In a pleasant surprise, the machine showed up in NYC on June 26th, five days before we arrived. For a minute, I was annoyed (at myself) for not having it delivered to VA, but I realized that it was a blessing to simply have it there when I arrived and I calmed down.

That gave me time to map out a plan of attack for transitioning from the laptop to the mini-PC (from now on, I’ll refer to it as the mini because it’s easier to type than UM790 Pro). I run Arch Linux on the laptop (and have for many years). On the laptop I was running X-Windows (Xorg to be more technically accurate) with the i3 Window Manager (a fantastic tiling window manager). I could have happily replicated that experience on the mini, possibly even by simply cloning the drives, but I really wanted to start fresh.

Starting fresh didn’t mean simply installing Arch from scratch and installing the same packages (in which case cloning would have made more sense). After reading about Wayland (the new graphical system in Linux) for years, and knowing that it wasn’t quite there (for way too long), I realized that it was somewhere between good enough and ready for prime time by now. I really wanted to find out, and I was willing to struggle a bit to be sure. I always had the laptop to fall back on, and I could easily wipe the mini and get Xorg running on it very quickly if needed.

That meant also having to choose a new WM (window manager), since i3 doesn’t run under Wayland (or at least people weren’t promoting it for that purpose). The simplest path was to use sway (a “compositor”, which is Wayland terminology for a WM in Xorg). Sway was built to be as i3 compatible as possible. Specifically, an i3 configuration file can work nearly unmodified in sway. It was an attractive proposition to be able to start with my existing config (which I had tweaked to my liking over the past few years) rather than learning a new system from scratch.

There are many Wayland compositors to choose from, including the much-hyped hyprland (see what I did there?), which might be more powerful than sway. I opted for simplicity, especially since I wasn’t even sure that Wayland would survive on my machine!

A quick backtrack! Since I bought the machine barebones, I had to supply my own RAM (memory) and SSD (disk, in this case solid state drives). Right after ordering the mini, I bought 64GB (2x 32GB sticks) of 5600MT/s DDR5 RAM from Amazon. I also bought 2x 2TB SSDs (Samsung 990 Pro) because they were on sale at a great price on Amazon. All of that was purchased the same day as the mini was ordered, so I had them for a month in advance of getting my hands on the mini…

Installing the RAM and SSDs in the mini was trivial. The only complaint about the mini is one I was aware of in advance from a YouTube video review of it. The rubber feet on the bottom of the unit are glued on, and cover the four screws that you need to access in order to open it. You have to peel off the rubber feet and then stick them back on. If you only do this once (or rarely), that will be fine (mine stuck back on and have held). But, if you open the box many times, it will likely become an issue…

I was now ready to begin the installation. I had a wireless keyboard and mouse to connect to the mini. All I needed was to connect a monitor. Nine years ago (nearly to the day), I bought a 24″ Dell monitor in a semi-emergency to diagnose an issue on one of my headless servers (that I could no longer ssh into). I plugged it in exactly twice over the first couple of years of owning it, and then I stuck it in a closet never to see the light of day again. I was excited to get it out and plug it in. Only, for the life of me, I couldn’t find it. I spent way too much time looking in every possible nook and cranny that I could have stuck it in, to no avail.

I gave up and plugged in my travel (portable) monitor, mentioned in my previous post. It worked fine (including in single-cable mode, where a USB-C to USB-C cable supplied both power and graphics to the portable monitor!). Now that I was able to boot and see what was going on, I proceeded to waste two days on a self-inflicted wound…

I bought this machine barebones on purpose. Not only to hand pick the RAM and SSDs (though that was the top reason), but also to not have Windows pre-installed. Given that, I had no reason to turn on Secure Boot (which Windows requires!). But, in the same spirit that I wanted to use Wayland (if possible), I figured I should do things the right way and keep Secure Boot on. In that same vein, I intended to finally switch from using GRUB as my bootloader to something else (more on that later). GRUB has worked perfectly well for me forever (just like Xorg), but people definitely point out all of its potential problems and complexities.

I decided to try rEFInd first. That’s supposed to be a nearly magical bootloader that just finds available operating systems to boot. It was able to find the USB thumb drive with my installation media on it, and install Arch, but it wasn’t able to boot Arch once it was installed, due to my stubborn desire to use Secure Boot.

I don’t give up on tech issues easily (my single biggest asset in my career!), so I spent way too much time Googling and following various suggestions, to no avail. I finally gave up and switched to systemd-boot. Same issue. I was able to boot the install media, but not the installed Arch. It took me a long time to give up on that as well!

Finally, in complete frustration and defeat, I decided to try GRUB. I got that to work. Ugh. I felt humiliated that seemingly every other Arch user could get Secure Boot to work with rEFInd or systemd-boot, but I could not.

While I had everything booting up now, I felt badly about settling. I came to the conclusion that I should turn off Secure Boot (I had no use for it) and try systemd-boot again. Unfortunately, I was a complete idiot, and could not figure out how to turn off Secure Boot. On the very first boot, I was offered the opportunity to turn off Secure Boot (but I consciously chose to keep it on). Once it was on, I couldn’t find a screen in the BIOS that would allow me to turn it off!

I reset the BIOS many times, expecting to see the original prompt, but never got it. Finally, in total frustration, I wrote to Minisforum support. They were incredibly responsive. It took two emails and I found the way to turn off Secure Boot (thank you Minisforum Support!). It was buried in a sub-menu that had a title that I didn’t associate with Secure Boot. So, my fault for not checking every possible sub-menu.

Once I turned it off, I was able to get systemd-boot to install and boot correctly.. Once I was satisfied with that, I removed GRUB from my system. Two full days later, and I was finally ready to actually work on my system…

At least I had my laptop working throughout, so I was able to keep up with emails and my other routines.

Getting sway running was both easy (I didn’t have to make too many changes to my i3 config file) and hard. Hard in the sense that while things worked, they didn’t necessarily work the way I wanted them to (e.g., windows didn’t open in the correct workspace). Most of those changes necessitated me learning the difference between window management in Wayland vs Xorg. It wasn’t hard, just tedious in tracking down all of the things I needed to change in the config file. Like I said above, I am tenacious when it comes to solving problems that I want to solve, and eventually, over the course of a few weeks, I nailed the config to my exact liking.

I’m extremely happy with both Wayland and sway!

Now it was time to retire the laptop and use the mini full time. Until this point, I was using the mini plugged in to the router with an Ethernet cable (because in NYC, I use the laptop on a tray table in bed and the mini was set up in the second room where the router sits). When I moved the mini into the bedroom, I had to switch to WiFi (even the barebones config has a high-end Intel WiFi/Bluetooth card included). Unfortunately, it didn’t work.

I Googled the error message, and it turns out that the chip was too new and there were no drivers included in the Linux kernel for it (of course, they can’t sell a chip without including a driver for Windows on day one!). But, it also turned out that there were already patches available for those who wanted to compile their own kernel (I did not). The patches will be included officially in the next kernel release, 6.5 (more on that in a minute).

Luckily, just like I bought the portable monitor in anticipation of traveling with a mini (not necessarily this one!), I also bought a USB WiFi stick a while ago (actually, it was one of my first Amazon Vine selections). That one also requires a loadable kernel module to work, but I installed that when I set up Arch, just in case. When I plugged in the USB stick, it worked right away. Whew.

Using the portable monitor for a few days straight made me wish I had found my old Dell monitor. In frustration, I mentioned that to Lois. She started to go look for it. I tried to stop her, saying that I had looked everywhere that it could possibly be. I told her that I specifically remember exactly where I put it the last time I used it (probably seven years ago!). She insisted on looking anyway.

Less than five minutes later, she comes back to the bedroom holding the monitor. I sheepishly ask where she found it. She says exactly where you said you put it. Oh man, as foolish as I felt, I was even happier that she ignored my pleas for her to not bother looking for it.

Now I had a 24″ monitor to work with, but it was only 1080p. The portable monitor was 2520×1680. The downgrade in resolution was painfully obvious, but the upgrade in sheer size (and hence ability to see everything clearly) was a big win. It took me a few minutes to realize why I was disappointed. My laptop was also only 1080p and I’d never been disappointed with it. In fact, I was heavily leaning toward sticking with that if I had gone with a new laptop!

It turns out that my laptop wasn’t exactly 1080p. It was 1920×1200 (technically FHD+, not FHD). I had gotten very used to that small amount of extra vertical space. In particular, seeing my very long folder list in Thunderbird (now showing fewer folders on the Dell monitor, causing me to scroll more often). I made the decision to buy a higher resolution monitor for the house, and a larger one too, since my desk at the house could accommodate it.

On Amazon Prime Day, I purchased an 27″ UHD/4K monitor by AOC (a Chinese brand that had a lot of good reviews). My original intent was to keep it in the box in NYC and simply bring it back to VA with us unopened. When it arrived, I changed my mind. I decided to try it first, to know whether I would be happy with the size and the significantly higher resolution. I’m very glad that I did.

It turned out that my tray table could handle a 27″ monitor, but likely no more than that. 3840×2160 was too small for most things at 27″ at the distance that I was from the monitor, so I ended up dropping the resolution to 2K (2560×1440) which turned out to be perfect.

It also ended up informing my decision to buy a new monitor for the house. I was definitely going to get a 32″ for the house, but what resolution should I go for? Amazon had an AOC monitor that was 32″ and topped out at 2K resolution (the same 2560×1440 that I was running the 27″ monitor at). It was even cheaper than what I paid on Prime Day for the 27″ monitor (because it was lower resolution).

I knew I’d be happy with that resolution (as I was very happy with it at 27″). But, I convinced myself that I should get a UHD/4K monitor, even if I ran it mostly at 2K, simply to be able to stream 4K content at native resolution if I wanted to (Netflix and YouTube have a reasonably large selection of true 4K content).

After much consternation, and reading too many reviews, I ended up buying a 32″ 4K monitor from Monoprice (directly), during one of their big sales. It is a VA panel (a term I had never even heard of, so I had to read a bunch of technical articles on the difference between IPS, VA and TN panels). There are compromises with VA, but none that really affect me (I’m not a gamer, I don’t do high-end graphics or video editing, etc.).

I’m extremely happy with the monitor, and I actually run it at the full 4K resolution full time (after experimenting with other resolutions), so it turned out to be a good decision.

When I got back to the house, it turned out the built-in WiFi card started working. Apparently someone snuck in the kernel patch for it in one of the dot releases of the 6.4 kernel line (probably 6.4.6). A little gift, since the USB WiFi stick is one of the bulkier ones and I didn’t love looking at it sticking up from my beautiful little mini.

I’ve had a handful of glitches with the Monoprice monitor (early on, zero issues since I stopped changing resolutions), and a single failure of the new WiFi driver (which isn’t supposed to even be in there), but otherwise, I couldn’t be happier with my new setup.

This machine is so over-the-top more capable than my needs, and I over-configured it with more RAM and SSD than I need, that it barely gets warm, let alone hot, and everything I do on it just hums along without a hiccup. The only thing left (other than pop the champagne) is to buy a travel keyboard so that I don’t have to lug a full-size one (which I’d have to do if we went on a trip today). While I’ll travel with a mouse, if I could find a travel keyboard with a built-in trackpad, just for ultra-convenience and flexibility, that would be even sweeter.



, ,



2 responses to “Trigger pulled on new PC, a UM790 Pro from Minisforum”

  1. Chris Walters Avatar
    Chris Walters

    I have the 690, not sure if I can justify the upgrade to the 790. Enjoy!

  2. hadar Avatar

    Given that I can barely push this thing on any of the cores (let alone all of them), I am 100% sure that I’d be perfectly satisfied with the 690 as well.

    This one ticked all of the boxes, and I am extremely happy with it!

    They just release an XTX variant of the 790, which would be even more overkill for my needs. 😉

Leave a Reply

Your email address will not be published. Required fields are marked *